Viewing 7 posts
  • #39842
    Thomas C
    Participant
    Posts: 12
    Threads: 36
    Joined: Jan 1970

      Hi,

       

      I’m trying to batch relink some .max files using Batch Render&Relink, but it doesn’t work: reading the log I see ‘Message=”Not find asset files in the file”Message=”Not find asset files in the file”‘

      What does it mean?

      Thanks so much,

  • #39844
    Posts: 254
    Threads: 1088
    Joined: Jan 1970

      There are a few reasons why you can get this message.

      1. You tried to relink files of the newer version of 3Ds Max.

      2. Files don’t contain assets.

      3. You use the Fast-Relink option with files older than 3Ds Max version 2010.

      If you still need to help please generate the support request and attach a few from these files

  • #39846
    Thomas C
    Participant
    Posts: 12
    Threads: 36
    Joined: Jan 1970

      Thank you.

      1. I can open the .max files. So I don’t think they are of a newer version of the one I use (which is 3ds Max 2023)

      2. Files do contain texture maps, but they have no path assigned (paths must have been stripped)

      3. I use Fast-Relink option but I’m pretty sure the .max files aren’t older than 3ds Max 2010

      I generated a support request and  just sent it to you.

      Thank you for the help and awesome work on this plugin.

    • #39857
      Posts: 254
      Threads: 1088
      Joined: Jan 1970

        Hello
        Thanks for the bug report.
        I tested the files that you sent and neither of them doesn’t contain the required information
        Usually, such files are saved with 3Ds max older than the 3Ds Max version.
        In any case, these files can`t be relinked with the “fast mode” option.
        You can always test them manually using 3ds max script commands

        getMAXFileAssetMetadata @”001_Vray.max” — undefined
        getMAXFileAssetMetadata @”002_Vray.max” — undefined

        getMaxFileVersionData @”001_Vray.max” — undefined
        getMaxFileVersionData @”002_Vray.max” — undefined

        Just uncheck the “fast mode” option to relink

        [Resolved]

  • #39872
    Thomas C
    Participant
    Posts: 12
    Threads: 36
    Joined: Jan 1970

      Thanks for your reply Oleksander.
      I unchecked the ‘fast mode’ option and it works  :)

      I’m thinking: it would be great if ‘fast mode’ could work even with ‘— undefined’ files.

      Isn’t it something achievable?

    • #39873
      Posts: 254
      Threads: 1088
      Joined: Jan 1970

        Excellent!

        Isn’t it something achievable?

        3D Max is the proprietary, closed file format, so I think this is a question for 3D Max developers

         

  • #39874
    Thomas C
    Participant
    Posts: 12
    Threads: 36
    Joined: Jan 1970

      It makes sense Oleksdandr.

      Anyway, thanks again for the help and for this great plugin!

       

Viewing 7 posts

You must be logged in to reply to this topic.